Posts: 62
Registered: ‎05-27-2015

My QVC app used to work beautifully. Yesterday it told me I had to update so I clicked update now. It took me to the playstore, and there was no update listed to update. I went back to the app, and it still told me I had to update. Playstore again had no update.


So, I uninstalled, reinstalled, and restarted my phone. When I then opened the app, it stopped (crashed) as soon as it opened.  I tried multiple times, and it did work once. But I got an error when trying to log in, and when I tried searching for "as is" "or hot pick" I got "no results".  


Also, when I clicked a catagory or new items there didn't seem to be a way to sort or filter.


Today the app is back to crashing when opening.  I got the option of reporting, which I did, but unless something changes I don't have the app. I uninstalled again as it's pretty much useless.


Can someome update on this? Am I the only one this is happening to?




Trusted Contributor
Posts: 1,936
Registered: ‎05-05-2010

Yesterday I tried to order a LOGO Black Friday priced top.  The app wouldn't let me.  I figured it was a "sign" that I wasn't supposed to have it and gave up. 

Posts: 62
Registered: ‎05-27-2015

Yeah, I can use the website on the browser, but I'll miss the app. It was so much faster. I'm not going to try and reinstall either as it will only frustrate me. Smiley Sad

Esteemed Contributor
Posts: 6,791
Registered: ‎08-18-2016

I have three devices @quick cooking mom   that I used for the QVC app.


What you described is what happened to my oldest phone. The app just isn't useable on that device's operating level.


That phone's OS can't be updated any more, and so can't handle the complexity of the QVC app any longer.

No problem with the other two (newer) devices using the app.

Posts: 62
Registered: ‎05-27-2015
Thanks Hedge, that may be my problem too. But I hate to get a new phone when this one works for me with everything else I do with it. I guess I'll just use the browser and website.