Reply
Honored Contributor
Posts: 16,149
Registered: ‎04-28-2010

It's always nice to know what others are experiencing.  Much better than thinking each of our computers need to be repaired or replaced.  Or, having to deal with Technical Support overseas, trying to figure out what's wrong. ...... which takes a lot of time.  We learn from others.  Good, informative thread, BTW. Heart

'More or less', 'Right or wrong', 'In general', and 'Just thinking out loud ' (as usual).
Honored Contributor
Posts: 16,905
Registered: ‎06-27-2010

 

I just noticed I'm not having the slow-down problems now that I'm using my iPad. Using my Mac is nearly impossible.

 

If this is consistent it makes me wonder if the IT staff attempted to correct the iPad problems we've been reporting and in the process "broke the site" for other devices. Remains to be seen.

 

 

⭐️Tact is the art of making a point without making an enemy. Howard W. Newton⭐️
Honored Contributor
Posts: 61,798
Registered: ‎03-10-2010

Re: Site slow to respond

[ Edited ]

The forums side of the site has been erratic as all get out now for two days and slow as molassas, more times than not. Here's the latest wrinkle... Maybe this has been said elsewhere, I don't know... Not that I should have to, but I switched over to IE and it appears to be working more normally.than when I was using Chrome, my preferred browser. I am absolutely flummoxed by what passes here for IT competence, and have been for years. The forums should work for users regardless of browser, they should work consistently and when they don't QVC should post something in an obvious location so that users are aware both that there are glitches and that QVC is aware of those glitches.

 

Edited to Add... It appears I spoke too soon. There are also a legion of glitches using IE... It is a bit better, but still not as it should be. I too am packing it in. Maybe they should alert the media when and if they EVER get it right...

 

Toodleoo Que... It's been real...


In my pantry with my cupcakes...
Trusted Contributor
Posts: 1,377
Registered: ‎05-02-2015

I am giving up. This is just ridiculous. Not even an explanation for the slowness. 

I Discovered That I Can Be Myself Without the Sky Falling In
Honored Contributor
Posts: 16,905
Registered: ‎06-27-2010

Re: Site slow to respond

[ Edited ]

 

The lack of actually acknowledging this problem the first day it was reported, and the continued silence from the support folks is as unsettling as this technical imbroglio, in my opinion.  There's something seriously wrong when it takes hours... then days... of reports by multiple posters and we see no prominent message at the top of all forums stating there is a problem, stating what the problem is, and offering updates on actions being taken.

 

Speaking as someone with a career in IT, I see this as a consistently dismal failure on QVC's part and I'm not sure it's worth the time and effort all of us have to expend.  I've repeatedly asked for a more professional tech support system here, even offered specific suggestions, and I know others have, too.  We're whistling into the wind, evidently.

 

 

⭐️Tact is the art of making a point without making an enemy. Howard W. Newton⭐️
Esteemed Contributor
Posts: 5,758
Registered: ‎03-09-2010

If you remember the last holiday (July 4th), we had a bit of technical issues.  I think this was done purposely because QVC has limited personal this holiday weekend and wanted to discourage posting.  

Discouraging posters also limits the chance of arguments and the need for moderators.

Keep Your Face To The Sunshine and You Will Not See The Shadow
Respected Contributor
Posts: 4,627
Registered: ‎03-10-2010

@dooBdoo wrote:

 

 

I just noticed I'm not having the slow-down problems now that I'm using my iPad.

 

 


 

I'm getting fairly decent response now, so the site might be functioning better now for all devices, not just iPads.

Honored Contributor
Posts: 61,798
Registered: ‎03-10-2010

Re: Site slow to respond

[ Edited ]

@dooBdoo wrote:

 

The lack of actually acknowledging this problem the first day it was reported, and the continued silence from the support folks is as unsettling as this technical imbroglio, in my opinion.  There's something seriously wrong when it takes hours... then days... of reports by multiple posters and we see no prominent message at the top of all forums stating there is a problem, stating what the problem is, and offering updates on actions being taken.

 

Speaking as someone with a career in IT, I see this as a consistently dismal failure on QVC's part and I'm not sure it's worth the time and effort all of us have to expend.  I've repeatedly asked for a more professional tech support system here, even offered specific suggestions, and I know others have, too.  We're whistling into the wind, evidently.

 

 


I fully agree and they are notorious for failing to timely acknowledge, timely alert users and timely address too frequent system glitches.  Arrogance, stupidity or both...


In my pantry with my cupcakes...
Honored Contributor
Posts: 61,798
Registered: ‎03-10-2010

@nomless wrote:

@dooBdoo wrote:

 

 

I just noticed I'm not having the slow-down problems now that I'm using my iPad.

 

 


 

I'm getting fairly decent response now, so the site might be functioning better now for all devices, not just iPads.


 

It's still a hot mess at my end...  Two days and counting...


In my pantry with my cupcakes...
Honored Contributor
Posts: 17,043
Registered: ‎03-09-2010

It's now Labor Day on the East Coast and its still stifling ssssllllllloooooowwwwww!!!

☼The best place to seek God is in a garden. You can dig for him there. GBShaw☼